Hulpartikel overzicht

Hulpartikel

cPanel: Ik wil de PHP-versie updaten

Onze voorgeïnstalleerde versie van cPanel / WHM komt standaard met CentOS als onderliggend besturingssysteem. CentOS gebruikt standaard vaak wat oudere versies van software (wel met recente security-updates) omdat het stabiliteit verkiest boven nieuwe features. Daarom ligt bijvoorbeeld de standaard PHP-versie vaak ook een aantal versies achter op wat er beschikbaar is. Wanneer je dan ook gebruik wilt maken van bijvoorbeeld PHP 7, zul je eerst zelf dit moeten inschakelen op jouw VPS.

Belangrijk om te weten!
- Het is niet zonder risico om de PHP-versie van jouw VPS te updaten. Maak dan ook altijd eerst een snapshot zodat je bij problemen hierop kunt terugvallen.
- Het is niet mogelijk om via de reguliere yum update een andere versie van PHP te verkrijgen. De packages voor PHP zijn bewust door cPanel buiten de standaard yum 'repository' gehouden. Je zult dan ook altijd PHP moeten updaten via de EasyApache software van cPanel of via het /usr/local/cpanel/scripts/phpup script.
- De huidige versie van PHP kun je altijd controleren via php -v in de console.
- Vanaf versie 62 van cPanel / WHM is EasyApache 4 de standaard applicatie voor het beheer van onder andere PHP. Gebruik je nog EasyApache 3 en je wilt van PHP 7 gebruik maken, dan zul je eerst naar EasyApache 4 moeten switchen. Bekijk de documentatie van cPanelvoor meer informatie.

Hoe gebruik ik EasyApache om PHP te updaten?
Stap 1: De WHM- en EasyApache-versie controleren
De huidige OS / WHM versie
  • Log in in jouw WHM installatie via je browser. Helemaal rechts bovenaan vind je informatie over de huidige installatie, waaronder de WHM-versie. Mocht het mogelijk zijn om te updaten, dan zie je daar direct een link voor.
  • Zodra je van de laatste versie van WHM gebruik maakt, ga je naar 'EasyApache' (Home > Software > EasyApache 4). Hier zul je waarschijnlijk 2 versies zien staan van EasyApache, 3 en 4. Versie 4 is inmiddels standaard en ook de enige die PHP 7 ondersteund. Klik op die optie.
  • Het kan zijn dat je vanaf een oudere versie van WHM bent geüpgraded en EasyApache 3 nog ingeschakeld is. In dat geval zie je deze melding: "EasyApache 4 is not available when EasyApache 3 is active." Daaronder staat ook een link naar de documentatie van hoe je naar EasyApache 4 kunt migreren. De samenvatting hiervan is dat je het onderstaande commando uitvoert (als root) via de console of via SSH:
    /scripts/migrate_ea3_to_ea4 --run
    . Je zult tijdens het uitvoeren nog wel een aantal malen een y moeten invoeren.
  • EasyApache is nu geüpdatet en je kunt deze software nu gebruiken om de PHP-versie aan te passen!

Stap 2: PHP updaten
EasyApache 4
  • Je kunt er nu voor kiezen om het bestaande profiel aan te passen, of een voorgeselecteerd pakket te gebruiken. Door op Customize te klikken kun je de huidige actieve configuratie aanpassen.
Voeg PHP 7 toe
  • Wanneer je nu aan de linkerkant voor PHP Versions kiest (de Apache opties laten we buiten beschouwing) kun je bijvoorbeeld PHP 7.0 en 7.1 ondersteuning toevoegen. Zet de schuifjes op Install en klik onderaan op Next.
  • Op de volgende pagina kun je PHP extensies / modules installeren, zoals bijvoorbeeld de ioncubeloader, mcrypt en soap. Klik weer op Next als je alle gewenste opties hebt aangeklikt.
  • Je krijgt nu een overzicht van alle aanpassingen. Klik onderaan op Provision om de wijzigingen door te voeren, dit kan soms wel enige tijd duren.

Stap 3: PHP-versie kiezen voor jouw website
Verander de PHP-versie
  • Om nu op jouw website nog gebruik te laten maken van de nieuwe PHP-versie log je in op cPanel zelf (standaard op https://jouwipdres:2083).
  • Zoek naar het kopje Software en kies daar de MultiPHP Manager.
  • Nu krijg je een overzicht van alle domeinen onder dat cPanel-account. Hier kun je elk domein aanvinken en daar de PHP-versie voor kiezen!

Heb je een goed idee?

Stuur jouw idee in! Met genoeg stemmen komt jouw idee op onze wishlist!

Heeft dit artikel je geholpen?

Maak een account aan of log in om een beoordeling achter te laten.

Reacties

Maak een account aan of log in om een reactie te plaatsen.

Kom je er niet uit?

Ontvang persoonlijke hulp van onze supporters

Neem contact op